SETPIECE Status - SETPIECE API is back up – Incident details
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Get updates
Dark mode
All systems operational
SETPIECE API is back up
Resolved
Major outage
Started 17 days ago
Lasted about 2 hours
Updates
Update
May 25, 2026 at 3:28 PM
Update
May 25, 2026 at 3:28 PM
This incident has been resolved.
Resolved
May 25, 2026 at 3:26 PM
Resolved
May 25, 2026 at 3:26 PM
SETPIECE API is back up. This incident was automatically resolved by Instatus monitoring.
Investigating
May 25, 2026 at 1:45 PM
Investigating
May 25, 2026 at 1:45 PM
SETPIECE API is down at the moment. This incident was automatically created by Instatus monitoring.